DHL Express - Rates and Create Label Errors
Incident Report for ShipEngine
Resolved
DHL Express identified the issue that was preventing some users from creating labels or getting rates. It has now been resolved.
Posted Oct 21, 2019 - 15:58 CDT
Investigating
We are currently investigating reports which are causing users being unable to create labels or get rates with DHL Express services.
Posted Oct 21, 2019 - 14:48 CDT
This incident affected: Shipping Carrier Integrations (DHL Express).