Increased UPS Response Times
Incident Report for ShipEngine
Resolved
UPS services have returned to normal.
Posted 10 months ago. Nov 09, 2018 - 13:29 CST
Investigating
We are currently investigating issues resulting in increased and timeouts when utilizing UPS services.
Posted 10 months ago. Nov 09, 2018 - 12:48 CST