DHL eCommerce - Errors Creating Labels
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 15:30 CST
Investigating
We have received reports of intermittent errors occurring from DHL eCommerce label requests and are investigating further.
Posted Nov 30, 2020 - 13:07 CST
This incident affected: Shipping Carrier Integrations (DHL E-Commerce).