Investigating Report of Degraded Stamps.com Services
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted 22 days ago. Aug 26, 2019 - 15:27 CDT
Monitoring
The issue has subsided and we are continuing to monitor performance.
Posted 22 days ago. Aug 26, 2019 - 15:19 CDT
Investigating
We are investigating reports of problems with Stamps.com services and will follow up as soon as we have additional updates to offer.
Posted 22 days ago. Aug 26, 2019 - 13:54 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).