Stamps.com - Creating Label Issue
Incident Report for ShipEngine
Resolved
The issue has been resolved and all systems are functioning normally. Thank you for your patience.
Posted Sep 08, 2020 - 16:00 CDT
Investigating
We’re experiencing an elevated level of errors with Stamps.com and are currently looking into the issue.
Posted Sep 08, 2020 - 14:28 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).