Issues Printing Postage
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally.
Posted Dec 02, 2019 - 13:36 CST
Update
We are continuing to work on a fix for this issue.
Posted Dec 02, 2019 - 11:29 CST
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some customers' ability to print postage and shipping labels. Users may experience higher-than-normal error rates and response times. Sorry for the inconvenience – Stamps.com should have a solution for this soon!
Posted Dec 02, 2019 - 11:10 CST
This incident affected: Shipping Carrier Integrations (Endicia, Stamps.com).