Create Label Slowness
Incident Report for ShipEngine
Resolved
This issue has been resolved.
Posted Jun 01, 2022 - 13:11 CDT
Update
We are continuing to investigate this issue.
Posted Jun 01, 2022 - 12:48 CDT
Investigating
We are currently seeing intermittent slowness when creating labels. Our engineering team is currently investigating.
Posted Jun 01, 2022 - 12:44 CDT
This incident affected: ShipEngine API.