Endicia - Printing postage issue
Incident Report for ShipEngine
Resolved
Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thank you for your patience!
Posted Apr 09, 2020 - 14:36 CDT
Identified
Endicia Engineers have identified an issue that may temporarily affect some customers' ability to print postage and shipping labels. We apologize for the inconvenience and they are expecting a resolution soon.

For more information please refer to Endicia status page here:
https://status.endicia.com/
Posted Apr 09, 2020 - 14:20 CDT
This incident affected: Shipping Carrier Integrations (Endicia).