Stamps.com and Endicia - Creating Label Issue
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience.
Posted Oct 29, 2020 - 09:04 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – they will have a solution for this soon.
Posted Oct 29, 2020 - 08:35 CDT
This incident affected: Shipping Carrier Integrations (Endicia, Stamps.com).