Stamps.com - Creating Label Issue
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thank you for your patience.
Posted Aug 03, 2020 - 15:55 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 03, 2020 - 15:44 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to get a rate and create a shipping label. They're expecting a resolution for this soon.

For more information please refer to their status page here: https://status.stamps.com/
Posted Aug 03, 2020 - 15:44 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).