Endicia Engineers have fixed the creating label issue and all systems are functioning normally. Thank you for your patience.
Posted Sep 18, 2020 - 13:59 CDT
Identified
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to create shipping labels. Sorry for the inconvenience – they should have a solution for this soon.
Posted Sep 18, 2020 - 13:11 CDT
This incident affected: Shipping Carrier Integrations (Endicia).