Stamps.com Postage Purchase
Incident Report for ShipEngine
Resolved
Stamps.com has reported that the issue has been resolved.

Thank you.
Posted 11 days ago. Aug 13, 2019 - 14:26 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some customers' ability to purchase postage.

For immediate updates, please refer to https://status.stamps.com/

We will update once we have more information.
Posted 11 days ago. Aug 13, 2019 - 13:57 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).