Stamps.com - Issue Creating Label
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the creating label issue and all systems are functioning normally. Thank you for your patience.
Posted Sep 18, 2020 - 13:58 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to create shipping labels. Sorry for the inconvenience – they should have a solution for this soon.

https://status.stamps.com/
Posted Sep 18, 2020 - 13:10 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).