Stamps.com - Issue Creating Label
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:21 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print shipping labels. Sorry for the inconvenience – they're expecting to have a solution for this soon.

https://status.stamps.com/
Posted Oct 19, 2020 - 11:42 CDT
Investigating
We’re experiencing an elevated level of errors with Stamps.com and are currently looking into the issue.
Posted Oct 19, 2020 - 11:31 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).