Stamps.com Issues
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 14:45 CST
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 09:51 CST
Investigating
We have received reports of increased errors returned from Stamps.com for labels and rates and are investigating this further.
Posted Nov 09, 2020 - 09:44 CST
This incident affected: Shipping Carrier Integrations (Stamps.com).