High rates of timeouts and nonspecific error responses from ShipEngine API

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Sep 26, 2023 - 12:30 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2023 - 12:11 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 26, 2023 - 11:15 CDT

Investigating

We are investigating widespread occurrences of timeouts and "An unexpected error occurred." error messages being returned on multiple endpoints.
Posted Sep 26, 2023 - 10:45 CDT
This incident affected: ShipEngine API.