Delay in receiving the tracking statuses from Royal Mail and Parcel Force

Incident Report for ShipEngine

Resolved

We started receiving statuses from the carrier.
Posted Aug 26, 2026 - 10:26 CDT

Identified

The issue is on the carrier's side, and they are trying to resolve it.
Posted Aug 26, 2026 - 10:05 CDT

Investigating

We identified a lack of status updates from the Raoyla Mail since yesterday. It is impacting our ability to share the statuses.
Posted Aug 26, 2026 - 10:03 CDT
This incident affected: Shipping Carrier Integrations (Royal Mail).