Endicia - Creating Label Issue
Incident Report for ShipEngine
Resolved
Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thank you for your patience.
Posted Jun 01, 2020 - 14:43 CDT
Identified
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. They're expecting a resolution for this soon.

For more information please refer to their status page here: https://status.endicia.com/
Posted Jun 01, 2020 - 13:33 CDT
This incident affected: Shipping Carrier Integrations (Endicia).