Stamps.com - Creating Label Issue
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the postage printing issue and all systems are functioning normally. Thank you for your patience.
Posted May 15, 2020 - 13:08 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. They're expecting a resolution for this soon.

For more information please refer to their status page here: https://status.stamps.com/
Posted May 15, 2020 - 12:26 CDT
Investigating
We are aware of and currently investigating reported issues related to label creation for Stamps.com services. We will provide updates as they are available and apologize for any inconvenience.
Posted May 15, 2020 - 12:20 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).