FedEx - Latency

Incident Report for ShipEngine

Resolved

This issue has been resolved.
Posted May 22, 2024 - 15:31 CDT

Investigating

We are investigating reports of errors and increased latency with FedEx label creation and rate shopping requests.
Posted May 22, 2024 - 12:42 CDT
This incident affected: Shipping Carrier Integrations (FedEx CA, FedEx UK, FedEx US).