Errors attempting to create and rate UPS labels
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 17:47 CDT
Update
An additional issue has been confirmed which is causing a low but persistent level of error responses to continue being returned for some users. The primary impact currently is slower than normal response times.

This issue is being addressed and we are continuing to monitor for a complete resolution.
Posted Jul 25, 2024 - 13:06 CDT
Monitoring
Error rates have returned to normal and we are monitoring to ensure a complete resolution.
Posted Jul 25, 2024 - 11:51 CDT
Investigating
We are investigating an issue causing 400 responses to be returned when attempting to rate UPS services and create UPS labels.
The error returned in association with this issue is: "Could not refresh authorization credentials in timely manner."
Posted Jul 25, 2024 - 10:30 CDT
This incident affected: Shipping Carrier Integrations (UPS US).