Disruption of address validation services

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 10:51 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 10:02 CDT

Investigating

We are currently investigating long response times and 5xx responses returned for attempts to validate addresses in ShipEngine.
Posted Jun 03, 2025 - 09:24 CDT
This incident affected: ShipEngine API.