FedEx Increased Response Times
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 13:44 CST
Monitoring
Response times have returned to normal. We are continuing to monitor this situation in the event response times begin climbing.
Posted Dec 02, 2019 - 13:22 CST
Investigating
We are currently experiencing higher than normal response times when communicating with FedEx. This may result in increased times to retrieve rates and to create shipping labels.
Posted Dec 02, 2019 - 11:51 CST
This incident affected: Shipping Carrier Integrations (FedEx US).