UPS Outage
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 12:20 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2024 - 12:05 CDT
Investigating
We are receiving reports of users receiving the error "A shipping carrier error occurred: Could not refresh authorization credentials in timely manner" when using UPS. We are aware of this issue and are currently investigating this.
Posted Sep 13, 2024 - 11:35 CDT
This incident affected: Shipping Carrier Integrations (UPS US).