USPS - Increased Latency
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 14:01 CST
Monitoring
A fix has been implemented and we are currently monitoring the status.
Posted Mar 08, 2024 - 13:11 CST
Investigating
We are investigating reports of higher than expected latency when getting USPS rates via Stamps.com and Endicia carriers.
Posted Mar 08, 2024 - 12:27 CST
This incident affected: Shipping Carrier Integrations (Endicia, Stamps.com).