Stamps.com - Timeouts and 400 responses when attempting to create USPS labels.
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jun 18, 2024 - 15:00 CDT
Monitoring
Error rates have dropped.

We are continuing to monitor for a full recovery.
Posted Jun 18, 2024 - 12:23 CDT
Investigating
We are seeing widespread errors when attempting to create labels with Stamps.com. Some instances present as a 504 while others as a 400 response and the following message returned:

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 40 - Could not open a connection to SQL Server)"

We are investigating the underlying cause
Posted Jun 18, 2024 - 11:49 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).