Investigating Report of Increased Timeout Errors
Incident Report for ShipEngine
Postmortem

One of our database nodes experienced a storage volume degradation, severely impacting performance, causing timeouts. After diagnosis, we proceeded to failover to our standby mirror, which restored normal operations.

As we do with all incidents, we’ll be taking the opportunity to review how it could have been prevented, and how any related processes can be improved.

Posted 21 days ago. Aug 27, 2019 - 14:10 CDT

Resolved
This incident has been resolved.
Posted 21 days ago. Aug 27, 2019 - 14:09 CDT
Monitoring
The reported timeout behavior has subsided and we are continuing to monitor the system activity.
Posted 21 days ago. Aug 27, 2019 - 13:59 CDT
Investigating
We are actively investigating reports of intermittent timeouts. We will update as more information is made available.
Posted 21 days ago. Aug 27, 2019 - 13:07 CDT
This incident affected: ShipEngine API.