Chat Connection Issues
Incident Report for ShipEngine
Resolved
The issue with our chat support service has been resolved and all systems are functioning normally. Thank you for your patience.
Posted Sep 21, 2020 - 12:00 CDT
Investigating
We have received recent reports of issues from our chat support service and are actively investigating.
Posted Sep 21, 2020 - 11:38 CDT
This incident affected: Support Services (Chat Support).