Account Dashboard Access Issues

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 17:15 CDT

Monitoring

Issues with the framework underlying dashboard login have been resolved allowing for user logins to succeed.
We are monitoring to ensure a complete resolution.
Posted Aug 21, 2025 - 15:24 CDT

Investigating

We are currently investigating an issue which is preventing user login to the account dashboard.
Posted Aug 21, 2025 - 13:23 CDT
This incident affected: ShipEngine API Dashboard.