Stamps Postage Purchase
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted 16 days ago. Oct 04, 2019 - 12:16 CDT
Update
Stamps.com engineers are continuing to work on a fix for this issue.
Posted 16 days ago. Oct 04, 2019 - 12:16 CDT
Identified
Stamps.com Engineers have identified an issue that may temporarily affect some customers' ability to purchase postage.

For immediate updates, please refer to https://status.stamps.com/

We will provide an update once we have more information or this has been resolved.
Posted 17 days ago. Oct 04, 2019 - 10:50 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).