Stamps.com - Unable to purchase postage
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 27, 2019 - 16:43 CDT
Monitoring
Stamps.com is believed to have resolved the issue.

We are continuing to monitor the issue and will update this incident accordingly.

All systems and processes are returning to normal.
Posted 23 days ago. Sep 27, 2019 - 16:06 CDT
Update
We are continuing to monitor the increased response times and related issues when purchasing labels, adding funds, and similar actions through USPS carriers.

Postage providers affected are currently Stamps.com and Endicia. You can find their respective status pages here:

Stamps.com: https://status.stamps.com/
Endicia: https://status.endicia.com/
Posted 23 days ago. Sep 27, 2019 - 13:58 CDT
Investigating
We are currently seeing increased response times in regards to creating labels and getting rates through Stamps.com. We are monitoring the situation.

Stamps.com's status page can be found here: https://status.stamps.com/
Posted 24 days ago. Sep 27, 2019 - 10:53 CDT
This incident affected: Shipping Carrier Integrations (Endicia, Stamps.com).