Stamps.com and Endicia Issues Creating Labels
Incident Report for ShipEngine
Resolved
Stamps.com and Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience.
Posted Oct 19, 2020 - 16:41 CDT
Update
We are continuing to investigate this issue.
Posted Oct 19, 2020 - 15:41 CDT
Investigating
We’re experiencing an elevated level of errors with Stamps.com and are currently looking into the issue.
Posted Oct 19, 2020 - 14:30 CDT
This incident affected: Shipping Carrier Integrations (Endicia, Stamps.com).