FedEx- Increased Latency
Incident Report for ShipEngine
Resolved
This has been resolved.
Posted Apr 04, 2024 - 12:26 CDT
Monitoring
We are seeing improved performance at this time, and we are continuing to monitor this.
Posted Apr 04, 2024 - 11:41 CDT
Investigating
We are investigating reports of higher than expected latency with FedEx rate and label creation requests.
Posted Apr 04, 2024 - 10:30 CDT
This incident affected: Shipping Carrier Integrations (FedEx CA, FedEx UK, FedEx US).