Shipsurance Temporarily Disabled
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 14:02 CDT
Investigating
We have identified an issue with purchasing Shipsurance and have temporarily disabled purchases while we investigate.

For more information, please contact support@shipengine.com
Posted Jul 01, 2021 - 13:17 CDT
This incident affected: Integrations (ShipSurance).