Increased Label Creation Time - Endicia
Incident Report for ShipEngine
Resolved
Label Creation times have returned to normal.
Posted 2 months ago. May 06, 2019 - 12:24 CDT
Investigating
We are aware of an issue causing increased response times when generating Endicia labels. We are in communication with Endicia about the issue and will update as we have more information.
Posted 2 months ago. May 06, 2019 - 12:13 CDT
This incident affected: Shipping Carrier Integrations.