Stamps - Issues Printing Postage
Incident Report for ShipEngine
Resolved
Stamps.com Engineers have fixed the login issue and all systems are functioning normally. Thank you for your patience.
Posted Aug 10, 2020 - 12:26 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 10, 2020 - 12:26 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we'll have a solution for this soon!
Posted Aug 10, 2020 - 12:04 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).