Stamps - Label Creation Issue
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jul 26, 2023 - 10:12 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2023 - 10:05 CDT
Update
We are continuing to investigate this issue.
Posted Jul 26, 2023 - 09:12 CDT
Investigating
Stamps.com has identified an issue that is affecting USPS label creation met with the error ‘internal error’. The issue is actively being investigated.
Posted Jul 26, 2023 - 08:00 CDT
This incident affected: Shipping Carrier Integrations (Stamps.com).