Account Dashboard Access Issues

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted May 12, 2026 - 15:02 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 14:17 CDT

Identified

An outage with a third party service provider has been identified as the cause of account dashboard login issues.
We are working with the provider to restore functionality.
Posted May 12, 2026 - 12:16 CDT

Investigating

We are aware of an issue preventing ShipEngine/ShipStationAPI dashboard access/login attempts from being completed successfully.
We are investigating the underlying cause.
Posted May 12, 2026 - 12:00 CDT
This incident affected: ShipEngine API Dashboard.