Endicia Postage Purchase
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 13, 2019 - 14:28 CDT
Update
Endicia has reported that the issue has been resolved.

Thank you.
Posted 2 months ago. Aug 13, 2019 - 14:28 CDT
Identified
Endicia Engineers have identified an issue that may temporarily affect some customers' ability to purchase postage.

For immediate updates, please refer to https://status.endicia.com/

We will update once we have more information.
Posted 2 months ago. Aug 13, 2019 - 14:10 CDT
This incident affected: Shipping Carrier Integrations (Endicia).