Carrier Issues - Canada Post

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 10:45 CDT

Update

We are continuing to monitor for any further issues.
Posted Mar 13, 2025 - 16:36 CDT

Monitoring

ShipEngine is aware of the technical issues impacting Canada Post. We are actively monitoring the status of these issues and will provide updates as they become available. Thank you for your patience!

You can also check the status at the carrier's status page, https://status.canadapost.ca/
Posted Mar 13, 2025 - 16:35 CDT
This incident affected: Shipping Carrier Integrations (Canada Post).