Increased Rate of Timeout Errors

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 13:10 CST

Monitoring

We have identified the cause of this issue.

A fix has been put in place, and we are monitoring the results.
Posted Feb 12, 2026 - 12:46 CST

Investigating

We are aware of an issue causing an increased rate of timeout errors across various endpoints for some users.

We are currently investigating this, and will provide an update once we have more information.
Posted Feb 12, 2026 - 12:28 CST
This incident affected: ShipEngine API.