DHL eCommerce Issues
Incident Report for ShipEngine
Resolved
The issues you were experiencing with DHL eCommerce have been resolved.
Thank you for your patience!
Posted Jan 18, 2022 - 11:14 CST
Identified
We identified an issue that is preventing users from using DHL eCommerce services. We are working to resolve this issue and will update you as soon as we have more information.

Thank you for your patience!
Posted Jan 18, 2022 - 10:00 CST
This incident affected: Shipping Carrier Integrations (DHL E-Commerce).