"An unexpected error occurred" returned on attempted label creation

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Sep 19, 2023 - 12:17 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2023 - 11:31 CDT

Investigating

We are investigating widespread reports of non-specific error responses for attempts to create labels with multiple carriers.
Posted Sep 19, 2023 - 10:59 CDT
This incident affected: ShipEngine API.