Create Label Latency

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Sep 01, 2023 - 10:32 CDT

Investigating

Some customers are experiencing intermittent slowness when creating labels. Our engineering team is currently investigating. We will provide an update as soon as one is available.
Posted Aug 31, 2023 - 13:00 CDT
This incident affected: ShipEngine API.