Royal Mail and Parcel Force performance degradation

Incident Report for ShipEngine

Resolved

The carrier solved the issue on his side, and the performance went back to normal.
Posted Jul 24, 2026 - 06:19 CDT

Monitoring

Carrier was contacted and is reviewing the issue on his side.
Posted Jul 24, 2026 - 04:56 CDT

Investigating

We are currently seeing performance degradation when calling the Royal Mail and Parcel Force APIs.
Posted Jul 24, 2026 - 04:40 CDT
This incident affected: Shipping Carrier Integrations (Royal Mail).