Unable to load account dashboard

Incident Report for ShipEngine

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 11:13 CDT

Investigating

We are currently investigating reports of a problem preventing some users from being able to successfully log into the account dashboard.
Posted Jun 01, 2026 - 10:59 CDT
This incident affects: ShipEngine API Dashboard.