DHL Express - Rating and Create Label Errors
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 17:50 CST
Monitoring
We have seen the DHL services returning to normal functionality.

We are continuing to monitor this to confirm the resolution of this incident.
Posted Nov 05, 2019 - 17:20 CST
Investigating
We have confirmed that DHL is encountering technical issues that is preventing some users from getting a rate or creating a label.

They are working on resolving the issue, and we will also update our status page as we receive any new information.
Posted Nov 05, 2019 - 15:30 CST
This incident affected: Shipping Carrier Integrations (DHL Express).