Problems preventing ShipEngine account dashboard access
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 15:56 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 15:39 CST
Investigating
We are investigating an issue preventing users from successfully accessing their account dashboard.

The following error is returned:
"Unexpected issue
We're encountering an unexpected issue preventing access to the Dashboard. Please try refreshing the page or contact support for immediate help. We appreciate your patience as we address this issue."
Posted Nov 18, 2024 - 15:25 CST
This incident affected: ShipEngine API Dashboard.