ShipEngine Outage
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 08:32 CDT
Identified
ShipEngine is aware of the technical issues impacting the ShipEngine Platform. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
- Ability to create and download label
Posted Jul 19, 2024 - 02:02 CDT
This incident affected: ShipEngine API.