General Latency

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 16:58 CDT

Update

We are continuing to investigate this issue.
Posted Jul 14, 2026 - 16:26 CDT

Investigating

We are aware of an issue causing latency when accessing ShipStation API, and we are actively investigating this issue. This is impacting multiple features, including label generation.
Posted Jul 14, 2026 - 16:24 CDT
This incident affected: ShipEngine API.